Discussion:
Query doesn't show all rows
(too old to reply)
Matthias Meckel
2017-05-19 07:29:06 UTC
Permalink
Hello,

I have only installed Semantic Wiki very recently.

When I try to use #ask I don't seem to get a complete list of rows.
When I first created this query I only got 15 rows. Now, many hours
later I get more, but still not all the rows

I have some ideas why that could be, but they are all speculation, so
my question is - is there something I can do to speed this up, i.e. to
get all rows displayed that should be displayed.


Here is the query
{{#ask:
[[Category:The Pen Addict Podcast]]
|?podcast episode number=Episode
|?podcast episode title=Title
|?podcast guest=Guests
|?podcast release date=Date
|?podcast length=Length (minutes)
|sort=podcast episode number
|order=ascending
|limit=400
}}

You can see the results here
https://stationery.wiki/index.php?title=The_Pen_Addict

Thank you for your help.

Matthias
Stephan Gambke
2017-05-19 10:52:42 UTC
Permalink
Try running runJobs.php from the MW maintenance directory.

-------- Original Message --------
Subject: [Semediawiki-user] Query doesn't show all rows
Local Time: May 19, 2017 9:29 AM
UTC Time: May 19, 2017 7:29 AM
From: ***@gmail.com
To: semediawiki-***@lists.sourceforge.net

Hello,

I have only installed Semantic Wiki very recently.

When I try to use #ask I don't seem to get a complete list of rows.
When I first created this query I only got 15 rows. Now, many hours
later I get more, but still not all the rows

I have some ideas why that could be, but they are all speculation, so
my question is - is there something I can do to speed this up, i.e. to
get all rows displayed that should be displayed.

Here is the query
{{#ask:
[[Category:The Pen Addict Podcast]]
|?podcast episode number=Episode
|?podcast episode title=Title
|?podcast guest=Guests
|?podcast release date=Date
|?podcast length=Length (minutes)
|sort=podcast episode number
|order=ascending
|limit=400
}}

You can see the results here
https://stationery.wiki/index.php?title=The_Pen_Addict

Thank you for your help.

Matthias

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
Semediawiki-***@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Matthias Meckel
2017-05-19 10:54:24 UTC
Permalink
Thank you very much for your help!
Post by Stephan Gambke
Try running runJobs.php from the MW maintenance directory.
-------- Original Message --------
Subject: [Semediawiki-user] Query doesn't show all rows
Local Time: May 19, 2017 9:29 AM
UTC Time: May 19, 2017 7:29 AM
Hello,
I have only installed Semantic Wiki very recently.
When I try to use #ask I don't seem to get a complete list of rows.
When I first created this query I only got 15 rows. Now, many hours
later I get more, but still not all the rows
I have some ideas why that could be, but they are all speculation, so
my question is - is there something I can do to speed this up, i.e. to
get all rows displayed that should be displayed.
Here is the query
[[Category:The Pen Addict Podcast]]
|?podcast episode number=Episode
|?podcast episode title=Title
|?podcast guest=Guests
|?podcast release date=Date
|?podcast length=Length (minutes)
|sort=podcast episode number
|order=ascending
|limit=400
}}
You can see the results here
https://stationery.wiki/index.php?title=The_Pen_Addict
Thank you for your help.
Matthias
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Matthias Meckel
2017-05-19 11:07:24 UTC
Permalink
Post by Stephan Gambke
Try running runJobs.php from the MW maintenance directory.
That didn't help.
I might try some of the functions from Special:SemanticMediaWiki if it
still doesn't work in the evening.

Best wishes
Matthias
Hermann Schwärzler
2017-05-19 13:05:00 UTC
Permalink
I looked at your page and it's really very strange!

If you open the category page it lists 280 pages but the ask query only
returns 77.

What kind of caching are you using? I.e what have you configured for
e.g. $wgMainCacheType?

Greetings
Hermann
Post by Matthias Meckel
Post by Stephan Gambke
Try running runJobs.php from the MW maintenance directory.
That didn't help.
I might try some of the functions from Special:SemanticMediaWiki if it
still doesn't work in the evening.
Best wishes
Matthias
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Matthias Meckel
2017-05-19 19:32:32 UTC
Permalink
Hello,

I haven't changed the cache configuration.
I found a probable reason for this issue

https://stationery.wiki/index.php?title=The_Pen_Addict doesn't show all pages.

https://stationery.wiki/index.php?title=The_Pen_Addict_1 is listed in
the results.
https://stationery.wiki/index.php?title=The_Pen_Addict_2 is NOT listed.

When you browse the properties for episode 1 at
https://stationery.wiki/index.php?title=Special:Browse/:The-5FPen-5FAddict-5F1
everything looks ok.

When you browse the properties for episode 2 at
https://stationery.wiki/index.php?title=Special:Browse/:The-5FPen-5FAddict-5F2
The category used in for my #ask has an issue:
Only pages in the namespace 'Category' are allowed here.

I don't see what the issue is. Both pages use
[[Category:The Pen Addict Podcast]]

Does anyone here have experience with this or a similar issue?

Best wishes and thanks for your help

Matthias

On Fri, May 19, 2017 at 2:05 PM, Hermann Schwärzler
Post by Hermann Schwärzler
I looked at your page and it's really very strange!
If you open the category page it lists 280 pages but the ask query only
returns 77.
What kind of caching are you using? I.e what have you configured for
e.g. $wgMainCacheType?
Greetings
Hermann
Post by Matthias Meckel
Post by Stephan Gambke
Try running runJobs.php from the MW maintenance directory.
That didn't help.
I might try some of the functions from Special:SemanticMediaWiki if it
still doesn't work in the evening.
Best wishes
Matthias
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
James HK
2017-05-19 23:48:21 UTC
Permalink
Hi,
Post by Matthias Meckel
When you browse the properties for episode 2 at
https://stationery.wiki/index.php?title=Special:Browse/:The-5FPen-5FAddict-5F2
Only pages in the namespace 'Category' are allowed here.
Page "The Pen Addict 1" has the "The Pen Addict Podcast" category
assigned, "The Pen Addict 2" does not and instead it shows a notice.

I'm guessing this to be related to [0] where "Category:The Pen Addict
Podcast" was redirected to non-category page which would explain the
notice you see as "Only pages in namespace "Category" are allowed
her…"

You can see that [1] shows the same symptom therefore after correcting
the category (meaning it to be in the Category namespace), and doing a
refresh (== purge) on those pages the assignments should be fixed.

PS: This specific error is currently not tracked as it appears outside
of the SMW namespace.

[0]
https://stationery.wiki/index.php?title=Category%3AThe_Pen_Addict_Podcast&type=revision&diff=2607&oldid=2296
[1] https://sandbox.semantic-mediawiki.org/wiki/Sp%C3%A9cial:Parcourir/:CategoryWithInvalidRedirectTarget

Cheers
Post by Matthias Meckel
Hello,
I haven't changed the cache configuration.
I found a probable reason for this issue
https://stationery.wiki/index.php?title=The_Pen_Addict doesn't show all pages.
https://stationery.wiki/index.php?title=The_Pen_Addict_1 is listed in
the results.
https://stationery.wiki/index.php?title=The_Pen_Addict_2 is NOT listed.
When you browse the properties for episode 1 at
https://stationery.wiki/index.php?title=Special:Browse/:The-5FPen-5FAddict-5F1
everything looks ok.
When you browse the properties for episode 2 at
https://stationery.wiki/index.php?title=Special:Browse/:The-5FPen-5FAddict-5F2
Only pages in the namespace 'Category' are allowed here.
I don't see what the issue is. Both pages use
[[Category:The Pen Addict Podcast]]
Does anyone here have experience with this or a similar issue?
Best wishes and thanks for your help
Matthias
On Fri, May 19, 2017 at 2:05 PM, Hermann Schwärzler
Post by Hermann Schwärzler
I looked at your page and it's really very strange!
If you open the category page it lists 280 pages but the ask query only
returns 77.
What kind of caching are you using? I.e what have you configured for
e.g. $wgMainCacheType?
Greetings
Hermann
Post by Matthias Meckel
Post by Stephan Gambke
Try running runJobs.php from the MW maintenance directory.
That didn't help.
I might try some of the functions from Special:SemanticMediaWiki if it
still doesn't work in the evening.
Best wishes
Matthias
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Matthias Meckel
2017-05-20 10:36:36 UTC
Permalink
Thank you very much!

Would the easiest way to get this fixed, except resaving those pages, be to
use rebuildData.php, as described at
https://www.semantic-mediawiki.org/wiki/Help:Repairing_SMW%27s_data
?

I was hoping to use the list generated by Semantic Mediawiki, instead of
the automatically generated list in the category.
Is there a way of achieving this? If a redirect, as done in [0] doesn't
work, then the only other way I can think of is to redirect to another page
in the category namespace, and put the semantic list there, but that seems
rather dodgy.

Thanks for your help and best wishes
Matthias
Post by Matthias Meckel
Hi,
Post by Matthias Meckel
When you browse the properties for episode 2 at
https://stationery.wiki/index.php?title=Special:Browse/:The-5FPen-5FAddict-5F2
Post by Matthias Meckel
Only pages in the namespace 'Category' are allowed here.
Page "The Pen Addict 1" has the "The Pen Addict Podcast" category
assigned, "The Pen Addict 2" does not and instead it shows a notice.
I'm guessing this to be related to [0] where "Category:The Pen Addict
Podcast" was redirected to non-category page which would explain the
notice you see as "Only pages in namespace "Category" are allowed
her…"
You can see that [1] shows the same symptom therefore after correcting
the category (meaning it to be in the Category namespace), and doing a
refresh (== purge) on those pages the assignments should be fixed.
PS: This specific error is currently not tracked as it appears outside
of the SMW namespace.
[0]
https://stationery.wiki/index.php?title=Category%3AThe_Pen_Addict_Podcast&type=revision&diff=2607&oldid=2296
[1]
https://sandbox.semantic-mediawiki.org/wiki/Sp%C3%A9cial:Parcourir/:CategoryWithInvalidRedirectTarget
Cheers
Post by Matthias Meckel
Hello,
I haven't changed the cache configuration.
I found a probable reason for this issue
https://stationery.wiki/index.php?title=The_Pen_Addict doesn't show all pages.
https://stationery.wiki/index.php?title=The_Pen_Addict_1 is listed in
the results.
https://stationery.wiki/index.php?title=The_Pen_Addict_2 is NOT listed.
When you browse the properties for episode 1 at
https://stationery.wiki/index.php?title=Special:Browse/:The-5FPen-5FAddict-5F1
Post by Matthias Meckel
everything looks ok.
When you browse the properties for episode 2 at
https://stationery.wiki/index.php?title=Special:Browse/:The-5FPen-5FAddict-5F2
Post by Matthias Meckel
Only pages in the namespace 'Category' are allowed here.
I don't see what the issue is. Both pages use
[[Category:The Pen Addict Podcast]]
Does anyone here have experience with this or a similar issue?
Best wishes and thanks for your help
Matthias
On Fri, May 19, 2017 at 2:05 PM, Hermann Schwärzler
Post by Hermann Schwärzler
I looked at your page and it's really very strange!
If you open the category page it lists 280 pages but the ask query only
returns 77.
What kind of caching are you using? I.e what have you configured for
e.g. $wgMainCacheType?
Greetings
Hermann
On Fri, May 19, 2017 at 11:52 AM, Stephan Gambke <
Post by Stephan Gambke
Try running runJobs.php from the MW maintenance directory.
That didn't help.
I might try some of the functions from Special:SemanticMediaWiki if it
still doesn't work in the evening.
Best wishes
Matthias
------------------------------------------------------------------------------
Post by Matthias Meckel
Post by Hermann Schwärzler
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
------------------------------------------------------------------------------
Post by Matthias Meckel
Post by Hermann Schwärzler
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
------------------------------------------------------------------------------
Post by Matthias Meckel
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
James HK
2017-05-21 04:15:06 UTC
Permalink
Hi,
Post by Matthias Meckel
Would the easiest way to get this fixed, except resaving those pages, be to
use rebuildData.php, as described at
https://www.semantic-mediawiki.org/wiki/Help:Repairing_SMW%27s_data
?
Yes, or if there are only a few pages left that have not yet been
purged, using the refresh button should help as well.
Post by Matthias Meckel
I was hoping to use the list generated by Semantic Mediawiki, instead of
the automatically generated list in the category.
As I mentioned this before since we don't track this particular error,
creating a list via SMW is currently not possible but [0] is expected
to handle this issue is a more discoverable fashion away from its
hidden existence.

[0] https://github.com/SemanticMediaWiki/SemanticMediaWiki/pull/2471

Cheers
Post by Matthias Meckel
Thank you very much!
Would the easiest way to get this fixed, except resaving those pages, be to
use rebuildData.php, as described at
https://www.semantic-mediawiki.org/wiki/Help:Repairing_SMW%27s_data
?
I was hoping to use the list generated by Semantic Mediawiki, instead of
the automatically generated list in the category.
Is there a way of achieving this? If a redirect, as done in [0] doesn't
work, then the only other way I can think of is to redirect to another page
in the category namespace, and put the semantic list there, but that seems
rather dodgy.
Thanks for your help and best wishes
Matthias
Post by Matthias Meckel
Hi,
Post by Matthias Meckel
When you browse the properties for episode 2 at
https://stationery.wiki/index.php?title=Special:Browse/:The-5FPen-5FAddict-5F2
Post by Matthias Meckel
Only pages in the namespace 'Category' are allowed here.
Page "The Pen Addict 1" has the "The Pen Addict Podcast" category
assigned, "The Pen Addict 2" does not and instead it shows a notice.
I'm guessing this to be related to [0] where "Category:The Pen Addict
Podcast" was redirected to non-category page which would explain the
notice you see as "Only pages in namespace "Category" are allowed
her…"
You can see that [1] shows the same symptom therefore after correcting
the category (meaning it to be in the Category namespace), and doing a
refresh (== purge) on those pages the assignments should be fixed.
PS: This specific error is currently not tracked as it appears outside
of the SMW namespace.
[0]
https://stationery.wiki/index.php?title=Category%3AThe_Pen_Addict_Podcast&type=revision&diff=2607&oldid=2296
[1]
https://sandbox.semantic-mediawiki.org/wiki/Sp%C3%A9cial:Parcourir/:CategoryWithInvalidRedirectTarget
Cheers
Post by Matthias Meckel
Hello,
I haven't changed the cache configuration.
I found a probable reason for this issue
https://stationery.wiki/index.php?title=The_Pen_Addict doesn't show all pages.
https://stationery.wiki/index.php?title=The_Pen_Addict_1 is listed in
the results.
https://stationery.wiki/index.php?title=The_Pen_Addict_2 is NOT listed.
When you browse the properties for episode 1 at
https://stationery.wiki/index.php?title=Special:Browse/:The-5FPen-5FAddict-5F1
Post by Matthias Meckel
everything looks ok.
When you browse the properties for episode 2 at
https://stationery.wiki/index.php?title=Special:Browse/:The-5FPen-5FAddict-5F2
Post by Matthias Meckel
Only pages in the namespace 'Category' are allowed here.
I don't see what the issue is. Both pages use
[[Category:The Pen Addict Podcast]]
Does anyone here have experience with this or a similar issue?
Best wishes and thanks for your help
Matthias
On Fri, May 19, 2017 at 2:05 PM, Hermann Schwärzler
Post by Hermann Schwärzler
I looked at your page and it's really very strange!
If you open the category page it lists 280 pages but the ask query only
returns 77.
What kind of caching are you using? I.e what have you configured for
e.g. $wgMainCacheType?
Greetings
Hermann
On Fri, May 19, 2017 at 11:52 AM, Stephan Gambke <
Post by Stephan Gambke
Try running runJobs.php from the MW maintenance directory.
That didn't help.
I might try some of the functions from Special:SemanticMediaWiki if it
still doesn't work in the evening.
Best wishes
Matthias
------------------------------------------------------------------------------
Post by Matthias Meckel
Post by Hermann Schwärzler
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
------------------------------------------------------------------------------
Post by Matthias Meckel
Post by Hermann Schwärzler
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
------------------------------------------------------------------------------
Post by Matthias Meckel
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Matthias Meckel
2017-05-22 19:55:29 UTC
Permalink
Thank you very much for your help.

So, even after the pull request it will still not work, but the error
message will make it more obvious what's going on.

I will keep looking whether I will find a way within (non semantic)
mediawiki to replace what the category page displays.

Best wishes and thank you for your help.

Matthias
Post by James HK
Hi,
Post by Matthias Meckel
Would the easiest way to get this fixed, except resaving those pages, be to
use rebuildData.php, as described at
https://www.semantic-mediawiki.org/wiki/Help:Repairing_SMW%27s_data
?
Yes, or if there are only a few pages left that have not yet been
purged, using the refresh button should help as well.
Post by Matthias Meckel
I was hoping to use the list generated by Semantic Mediawiki, instead of
the automatically generated list in the category.
As I mentioned this before since we don't track this particular error,
creating a list via SMW is currently not possible but [0] is expected
to handle this issue is a more discoverable fashion away from its
hidden existence.
[0] https://github.com/SemanticMediaWiki/SemanticMediaWiki/pull/2471
Cheers
Post by Matthias Meckel
Thank you very much!
Would the easiest way to get this fixed, except resaving those pages, be to
use rebuildData.php, as described at
https://www.semantic-mediawiki.org/wiki/Help:Repairing_SMW%27s_data
?
I was hoping to use the list generated by Semantic Mediawiki, instead of
the automatically generated list in the category.
Is there a way of achieving this? If a redirect, as done in [0] doesn't
work, then the only other way I can think of is to redirect to another page
in the category namespace, and put the semantic list there, but that seems
rather dodgy.
Thanks for your help and best wishes
Matthias
Post by Matthias Meckel
Hi,
Post by Matthias Meckel
When you browse the properties for episode 2 at
https://stationery.wiki/index.php?title=Special:Browse/:The-5FPen-5FAddict-5F2
Post by Matthias Meckel
Only pages in the namespace 'Category' are allowed here.
Page "The Pen Addict 1" has the "The Pen Addict Podcast" category
assigned, "The Pen Addict 2" does not and instead it shows a notice.
I'm guessing this to be related to [0] where "Category:The Pen Addict
Podcast" was redirected to non-category page which would explain the
notice you see as "Only pages in namespace "Category" are allowed
her…"
You can see that [1] shows the same symptom therefore after correcting
the category (meaning it to be in the Category namespace), and doing a
refresh (== purge) on those pages the assignments should be fixed.
PS: This specific error is currently not tracked as it appears outside
of the SMW namespace.
[0]
https://stationery.wiki/index.php?title=Category%3AThe_Pen_Addict_Podcast&type=revision&diff=2607&oldid=2296
[1]
https://sandbox.semantic-mediawiki.org/wiki/Sp%C3%A9cial:Parcourir/:CategoryWithInvalidRedirectTarget
Cheers
Post by Matthias Meckel
Hello,
I haven't changed the cache configuration.
I found a probable reason for this issue
https://stationery.wiki/index.php?title=The_Pen_Addict doesn't show all pages.
https://stationery.wiki/index.php?title=The_Pen_Addict_1 is listed in
the results.
https://stationery.wiki/index.php?title=The_Pen_Addict_2 is NOT listed.
When you browse the properties for episode 1 at
https://stationery.wiki/index.php?title=Special:Browse/:The-5FPen-5FAddict-5F1
Post by Matthias Meckel
everything looks ok.
When you browse the properties for episode 2 at
https://stationery.wiki/index.php?title=Special:Browse/:The-5FPen-5FAddict-5F2
Post by Matthias Meckel
Only pages in the namespace 'Category' are allowed here.
I don't see what the issue is. Both pages use
[[Category:The Pen Addict Podcast]]
Does anyone here have experience with this or a similar issue?
Best wishes and thanks for your help
Matthias
On Fri, May 19, 2017 at 2:05 PM, Hermann Schwärzler
Post by Hermann Schwärzler
I looked at your page and it's really very strange!
If you open the category page it lists 280 pages but the ask query only
returns 77.
What kind of caching are you using? I.e what have you configured for
e.g. $wgMainCacheType?
Greetings
Hermann
On Fri, May 19, 2017 at 11:52 AM, Stephan Gambke <
Post by Stephan Gambke
Try running runJobs.php from the MW maintenance directory.
That didn't help.
I might try some of the functions from Special:SemanticMediaWiki if it
still doesn't work in the evening.
Best wishes
Matthias
------------------------------------------------------------------------------
Post by Matthias Meckel
Post by Hermann Schwärzler
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
------------------------------------------------------------------------------
Post by Matthias Meckel
Post by Hermann Schwärzler
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
------------------------------------------------------------------------------
Post by Matthias Meckel
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Semediawiki-user mailing list
https://lists.sourceforge.net/lists/listinfo/semediawiki-user
Loading...